
Quick Start Guide: Texture your space crate  1 
Diploma in Animation Level 5 
Yoobee College of Creative Innovation (2023) 

 

Quick Start Guide 
Texture your space crate 
Contents 
Create a UV layout (Maya) ....................................................................................................................... 2 

Create an occlusion map and select Lambert material (Maya) ................................................................. 5 

Create texture maps: Colour map (Maya and Adobe Photoshop) ............................................................. 8 

A. UV snapshot and texture set up (Maya and Adobe Photoshop)........................................................ 8 

B. Using a texturing workflow (Maya) ................................................................................................ 12 

C. Adding detail to texture (Maya) ..................................................................................................... 16 

D. Adding more detail and interest to texture (Adobe Photoshop and Maya) ..................................... 20 

Create texture maps: Bump and Specular maps (Maya) ......................................................................... 25 

A. Create a bump map (Maya) ........................................................................................................... 25 

B. Create a specular map (Maya) ....................................................................................................... 29 

Review textured space crate and save ................................................................................................... 32 

 

  



Quick Start Guide: Texture your space crate  2 
Diploma in Animation Level 5 
Yoobee College of Creative Innovation (2023) 

 

Create a UV layout (Maya) 
These five steps guide you through creating a new UV layout in Maya using the planar projection tool, 

projecting the UVs, and verifying your UV map in the UV texture editor. 

Step Action 

1 Understand UV points in Maya: 

• UV points in Maya dictate texture placement on a model's surface.  

• Default UV layouts are generated for base meshes, but additional UV points created 
during modelling may not align with the new surface layout, requiring remapping to 
avoid texture distortion. 

 
2 Use Maya’s UV projection tools: 

• Use Maya's UV projection tools to establish a new UV layout by taking a snapshot of 
the model's surface.  

• Choose from various UV projection tools based on shape: 

Tool type Description 

Planar 
projection 

Intended for use on planar surfaces with options to project in different 
axes depending on the orientation of the surface to be mapped. 

Cylindrical 
projection 

Intended for use on cylindrical surfaces. The projection wraps around 
the cylinder to get the UV location for all points of the curve. 

Spherical 
projection 

Intended for use on spherical surfaces. Again, the projection wraps 
around the sphere to get the UV location for all points of a sphere. 

Automatic 
projection 

Takes a projection of 3 axes at the same time and combines them into 
the UV map. •  
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3 Choose planar projection: 

• Choose planar projection for a mostly flat, axis-oriented model like your space crate.  

• Select faces aligned with axes for mapping the UV points: 
o Top and bottom: you planar project along the Y-axis 
o Left and right: you planar project along the X-axis 
o Front and back: you planar project along the Z-axis for front and back. 

 

4 Select faces for top and bottom planar projection: 

• For top and bottom planar projection, select the centre face of the top and bottom 
surfaces.  

• Use Shift+ to increase the selection incrementally (i.e. by one full face each time you use 
Shift+). 

 
5 Use planar projection tool: 

• Use the planar projection tool by navigating to Create UVs > Planar Mapping > □.  

• In the options, choose Project from Y-axis and click apply.  

• Keep the planar mapping options window open, repeating the process for left, right, 
front, and back faces. 
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• Once you have completed projecting all the faces of your model, your UV map should 
look like this: 

 
6 Verify UV projection: 

• Verify the completed UV projection by checking the UV map in the UV Texture Editor, 
accessible through the Polygons shelf or Window > UV Texture Editor. 
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Create an occlusion map and select Lambert material (Maya) 
These six steps guide you through creating an occlusion map in Maya to generate shading information 

for your model, selecting Lambert from the material list to establish basic surface properties, and 

assigning the selected material to your model. 

Step Action 

1 Understand occlusion in Maya: 

• Occlusion in Maya calculates how close objects or surfaces are to each other. The 

closer a surface or object is, the darker a greyscale value is, resembling how light falls 

off when surfaces come together and exclude light from each other’s surfaces. 

• To paint a texture for your model using your new UV layout, you bake an occlusion 

map to provide you with free shading information to use on your model’s texture. 

2 Create occlusion map: 

• Create an occlusion map in Maya by navigating to Color > Batch Bake (Mental Ray) > □ 

Tip: Don’t have this navigation option? Enable the Mental Ray plugin for Maya – go to 
Window>Settings and Preferences>Plugin Manager, scroll down to Mental Ray and ensure you 
check both boxes to enable Batch Bake. 

• Configure settings:  
o Bake set override 
o Colour mode: Occlusion 
o X resolution: 1024 
o Y resolution: 1024 
o Fill texture seams: 32 

• Click Convert to generate the occlusion map. Once progress is complete, your 
occlusion map should look like this: 
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3 Understand materials in Maya: 

• Materials in Maya are important for texturing because they define how an object 
interacts with light and how its surface properties behave. 

• To integrate a material in Maya into your model’s texture, you use the Hypershade 
window, which is where all materials are stored and managed. 

• The Hypershadow window looks like this (the areas labelled A, B, C, and D are 
explained below): 

 

Area Purpose 

A A list of all the different material types, utilities, and textures available in 
Maya. You bring materials into your scene by left-mouse clicking on the 
required item. 

B A search and organisation list. If you select an option (surface, for example), 
the list in area A will update and only show you objects of that type, a very 
quick method to find a desired shader or material type. 

C All the materials used in the scene are stored here. There will always be a 
default Lambert, Particle, and shader Glow here. Lambert 2 was created by 
Maya when Geoff baked his occlusion map. 

D The work area. When working on a shading network, you will work in this 
window. 

 

4 Open Hypershade window 

• Access the Hypershader window in Maya by going to Window>Rendering 
Editors>Hypershade. 
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5 Select Lambert material: 

• In the Hypershade window, select Lambert (the most basic material type in Maya) from 
the material list.  

• Rename the Lambert material (e.g., Spacecrate_Shader) in the Attribute Editor 
window: 

 
6 Assign material to model: 

• Assign the Spacecrate_Shader material to your model: 
o Middle-click and hold on the shader in the Hypershade window.  
o Drag and drop it onto your model in the viewport, returning the model to a 

default grey colour. 
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Create texture maps: Colour map (Maya and Adobe Photoshop) 
These four tables guide you through essential steps, from setting up the UV snapshot and incorporating 

the occlusion map, exploring various texturing workflows, adding detailed elements like scuffs and 

scratches, and enhancing overall texture interest using Maya and Adobe Photoshop. 

A. UV snapshot and texture set up (Maya and Adobe Photoshop) 
You need to bring in the UV layout and the Occlusion map you baked earlier and start creating your 

colour map in Adobe Photoshop. 

Step Action 

1 Export UV snapshot from Maya: 

• In UV Texture Editor, go to Polygons > UV Snapshot.  

• Set Size X and Y to 1024 pixels, and Image format to JPEG.  

• The UV snapshot will saved at the location path stated in Filename. Click OK. 

 
2 Open UV snapshot in Adobe Photoshop: 

• Navigate to the location where your UV Snapshot is saved and open it in Adobe 
Photoshop: 

 
• Notice the lines – they show you where your model’s edges are for accurate texture 

painting. 

  



Quick Start Guide: Texture your space crate  9 
Diploma in Animation Level 5 
Yoobee College of Creative Innovation (2023) 

 

3 Save UV snapshot as TIFF: 

• Save the UV Snapshot in Adobe Photoshop as a TIFF file with a meaningful name, 
selecting these options: 

o Image compression: None 
o Layer compression: RLE  

 
• Save all texture files in the sourceimages folder of the project file structure: 
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4 Locate occlusion file to add to texture file: 

• In Maya’s Hypershade window, right-click the occlusion file and drag to Graph 
Network. This moves the shader file into the working area of the Hypershade window 
and opens the network so you can see all the nodes attached to the shader file. 

• Select the center file node. 

5 Find and save occlusion data: 

• In the Attribute Editor, find the file location.  

 
• Save the occlusion data as a new layer beneath the UVs in the TIFF file. 

 
6 Invert UV values:  

• With the UV layer selected, go to Image > Adjustments > Invert (Ctrl+I). 
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7 Set blend mode: 

• Set the layer's blend mode to Multiply, making white values transparent for reference. 
This makes all the white values of the layer transparent allowing you to see the layers 
beneath and the black UV lines for reference when painting your texture map.   

• Lock the layer so you do not accidentally move it when painting the texture. 

8 Set occlusion layer: 

• Set the Occlusion layer to Multiply for shading so that the grey values shade your 
texture as you paint it, giving you the dark areas where the mesh has cracks and 
crevices.  

• Lock this layer as well. 
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B. Using a texturing workflow (Maya) 
Various workflows exist for creating colour and texture information for 3D models. As you engage in 

more modelling and texturing work, develop your unique workflow based on personal preferences.  

Follow best practices, including setting up shading networks, using good naming conventions, and 

maintaining an organised file structure. 

Step Action 

1 Method breakdown: 

• Examine the following method (i.e. as described in this table) used to texture the 
space crate in this completed example: 

 
• For the overall crate colour, Geoff used a sourced photographic texture. You can 

source textures by downloading packs, capturing your own images, or creating 
textures from scratch. 
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2 Add texture to 3D model:  

• In Hypershade, select the Spacecrate_Shader material.  

• Click the checkered box next to the colour attribute in the Attribute Editor. 
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3 Choose and locate texture file:  

• In the Create Render Node window, select ‘file’ from the list of nodes on the right.  

 
• In the Attribute Editor, click on the file icon and navigate to where you saved your 

texture file. It should be in the source images folder in the Maya project file system. 

4 Display texture on model:  

• Ensure that your texture is displayed on the model.  

• If it still appears in the default grey colour, press the 6 key to enable shading with 
texture in the viewport. 
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5 Quickly update and view texture:  

• Every time you save your texture file while working, update and view your texture 
quickly by clicking the reload button from the file node in the attribute editor. 
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C. Adding detail to texture (Maya) 
Add detail to the texture by creating scuffs and scratches around the edges where the crate would get 

banged about while in use. To do this, you create a new layer that resembles brushed bare metal and then 

paint a mask on the bare metal layer that will only reveal the metal where you paint the mask. 

Step Action 

1 Create a metal layer: 

• Add a new layer and fill it with a mid-shade of grey.  

• Go to Filter > Noise > Add Noise. 

 
2 Apply motion blur: 

• Enhance the metal layer with motion blur. Go to Filter > Blur > Motion Blur.  

 
• Use Angle: -27°, Distance: 33 pixels. 
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3 Add a layer mask: 

• Add a layer mask to the brushed metal layer. The mask controls visibility.  

• Click the FX button next to the layer mask button. 

 
4 Edit the layer mask: 

• The mask's canvas, when filled with black, is transparent. Use the brush tool with pure 
white to reveal brushed metal areas.  

• Correct mistakes by repainting with pure black. 

 
5 Fine-tune with layer styles: 

• Apply layer styles to mimic rust. Click the FX button next to the layer mask button.  
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• Use provided settings: 

 
• Paint the mask to add rust effects. 

6 Refine mask for realism: 

• Continue refining the mask to reveal bare metal and rusty parts, simulating wear and 
tear. 
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7 Review and check progress: 

• Click the Reload Texture button to check the model's progress.  

• Save your texture file before reviewing. 
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D. Adding more detail and interest to texture (Adobe Photoshop and Maya) 
The texture is still a little basic and dull, so add more detail to it to make your space crate more 

interesting. 

Step Action 

1 Enhance warning stickers:  

• Roughen up the stripes with warning stripes by using various methods like manual 
painting or colour range selection. 

 
 
Tip: One way to achieve this is to manually paint over the stripes, add roughness to the edges, 
add scratches, etc. Another method is to use the painted texture on the crate itself to select 
parts of the warning stripes – Adobe Photoshop has a nifty selection tool that allows you to 
select a colour range of a layer. 

2 Use colour range selection:  

• Turn off visibility for stripes and UV layers.  

• Go to Select > Color Range.  

• Sample a grungy area of the crate texture using the eye dropper. 

• Adjust the selection using the Fuzziness range slider and confirm. 

3 Reverse and refine selection:  

• Turn on warning stripes and select the layer.  

• Invert the selection (Select > Inverse or Shift+Ctrl+I).  

• Delete outer edges.  

• Invert again to select inside and soften stripes using Eraser Tool with a soft brush and 
low opacity. 

• Save and reload the texture in Maya to see the result: 
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4 Add even more detail:  

• Address the lack of detail by adding a new rusty paint texture to the center of the 
crate.  

• Use color range selection to blend the new texture into the overall texture map. 

 
5 Balance detail across model:  

• Now, the model's centre looks more interesting, but it also looks really detailed and 
grungy compared to the rest of the texture map. 

 
• To balance detail, repeat steps for the rest of the model using the texture from the 

centre panel.  

• Use color range selection , layer blend modes, and opacity slider for blending. 
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6 Flatten layers and save:  

• Once satisfied with the texture, flatten the layers, save, and reload in Maya. 

 
7 Centre panel markings:  

• Add markings to the centre panel using layer styles to create embossed markings.  

• Click the FX button next to layer masks: 
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• Choose the Bevel & Emboss layer style with specified settings: 

 
8 Apply layer mask:  

• Use a layer mask to apply the bevel effect where you paint on the centre panel.  

 
• Paint details with a black value, and use white to correct mistakes. 

 
9 Add rust effect:  
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• Further enhance indentations with an inner glow layer style to simulate rust: 

 
10 Save and reload:  

• Save the texture file and reload it in Maya to see the final result: 
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Create texture maps: Bump and Specular maps (Maya) 
These two tables guide you through enhancing your 3D model's visual appeal by creating a bump map 

for surface relief and a specular map for controlling highlights. 

A. Create a bump map (Maya) 
Step Action 

1 Understand bump maps:  

• Bump maps are greyscale textures used to simulate surface relief on a model. They 
add subtle detail by creating elevations and depressions.  

• Avoid using them for large relief details, which should be part of the model's 
geometry.  

• Dark values of a bump map lower the model’s surface, while light values raise it. 

2 Create bump map from colour map:  

• Save the colour map as a new TIFF file called Spacecrate_Bump.tiff.  

• Use the colour range selection tool to select details. 

• Adjust selection using the fuzziness slider. 

• Invert selection, and fill with black.  

 
• Adjust contrast using Image>Adjustments>Hue and Saturation.  

• Remove any remaining colour information using the saturation slider and adjust the 
brightness to reduce the levels of white values. 

• The centre panel details in the map should be recessed into the model. Paint the 
details in solid black so that they register as a depression in the surface of the model 
when the bump is applied in Maya. 

• Save your file. 

3 Integrate bump map into shading network:  

• Open the Hypershade window in Maya. 

• Right-click on the Spacecrate shader, drag downwards, and select Graph Network to 
bring it into the work area. 

• In the Attribute Editor, click the checker box next to the bump map attribute. 

• Select File from the nodes window and choose the bump map file. 
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4 Visualise bump map effect: 

• Render a frame using the Render the Current Frame button in Maya. It looks like an 
old film clapper board: 

 
 

Button Name Function 

1 Open render 
window: 

Opens the render window without rendering a 
frame. 

2 Render the 
current frame: 

Opens the render window and renders the current 
frame. 

3 Enables IPR 
Rendering 

Opens the render window and enables interactive 
photorealistic rendering. IPR render engine renders 
the frame as you adjust your scene.  

4 Render Settings: Opens the render settings window where you can 
change render settings like size, number of frames, 
render camera, frame names etc. 

• Render the current frame: 
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5 Adjust bump strength: 

• Observe the initial bump map effect on the model – you’ll notice that the bump map 
is very strong due to the default value of the bump being set too high. 

• Adjust the bump strength by selecting the bump2D node in the Hypershade window. 

6 Adjust render settings and evaluate: 

• Before rendering again, click Keep Image to store the current render: 

 
Tip: This handy feature stores the current render so that you can compare renders when 
changing small details of your scene, for example, adjusting bump values. Note: if you close 
the render window, all stored renders in memory will disappear. So, if you want to keep a 
render, you can save it using File>Save Image. 

• Render again using the Render button(clapper board button on the far left directly 
under the File menu). 

• Use the render window's scroll bar to compare the initial and adjusted renders. 
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7 Adjust bump strength for a subtle effect 

• Continue tweaking bump strength until you are happy with the amount of bump – aim 
for a subtle bump, as it looks much better than a strong one. 
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B. Create a specular map (Maya) 
Step Action 

1 Understand specular highlights:  

• Specular highlights reveal where light reflects in consistent angles on the object like a 
mirror. 

• Not all materials in Maya have specular attributes, as observed in the Lambert material 
you’re using in your shading network (Lambert does not reflect any light in your 
scene). 

2 Switch material type to Phong: 

• Open the Hypershade window and locate the material node for the Lambert material. 

• Alternatively, select the Lambert material from the top materials area in the 
Hypershade window. 

• In the Attribute Editor, change the material type to Phong from the drop-down menu. 
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3 Configure new attributes for specularity: 

• Note the introduction of new attributes that control specularity in the Attribute Editor: 

 
•  

4 Adjust reflectivity for varied highlights: 

• Note that the default settings will result in uniform shininess without variation or 
reference to the colour map. You need a map to guide the render engine on areas for 
specular highlights (see Step 5 below). 

• Set the reflectivity attribute to 0 for minimal reflectivity – this will align with the aged 
and worn state of a space crate, which should not reflect light. 

5 Understand specular maps: 

• Specular maps, like bump maps, are greyscale. 

• Light-colored areas in a specular map reflect more highlights, while dark areas reflect 
less. 

6 Use existing bump map as a specular map: 

• Leverage the existing bump map as a specular map to control specularity based on the 
model's features. 

Tip: This will not always be the case. So, when making your own models, you’ll need to decide 
what areas of the model should be shiny and reflective and design a specular map accordingly. 

• Add the specular map to the shading network by clicking the checker box next to 
specular colour and selecting the file. 

• Click on the folder icon in the file node and add the bump map to the file.  

• Your completed shading network should look like this: 
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7 Review specular highlights: 

• Render the scene to observe areas with varying specular highlights on the model. 

• Verify that the reflectivity aligns with the intended appearance of the aged and worn 
space crate. 

• Adjust settings or revisit the specular map design if necessary for the desired visual 
outcome. 
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Review textured space crate and save 
These three steps guide you through reviewing your textured space crate and saving it to JPG format. 

Step Action 

1 Review your model: 

• You should now have a completed textured space crate that looks like this: 
  

•  
2 Render your scene: 

• Go to the Rendering menu and choose Render > Render Current Frame or Render 
Sequence. 

• Once rendering is complete, you can view the rendered image in the Render View 
window. 

3 Save the image: 

• In the Render View window, go to File > Save Image. 

• Choose the desired image format. If JPG is unavailable, you might choose another 
common format like PNG. 

• Specify the destination folder and filename and click Save to save the rendered image 
in the chosen format. 

 

 


